Balancer - Degraded Performance

Incident Report for Adra Suite

Resolved

This incident has been resolved.
Posted Dec 12, 2025 - 08:36 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 11, 2025 - 21:32 UTC

Investigating

We are currently seeing some issues with degraded performance in Balancer that might affect some customers.
We are investigating the issue and will soon provide an update.
Posted Dec 11, 2025 - 16:15 UTC
This incident affected: Balancer (Balancer US).