SETUP: Legal Entity Service Interruption

Incident Report for Adra Suite

Resolved

This incident has been resolved.
Posted May 30, 2025 - 21:02 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 30, 2025 - 19:17 UTC

Investigating

The Legal Entity service is currently unavailable. We're working quickly to bring it back online and will keep you updated. We are sorry for the inconvenience this may cause.
Posted May 30, 2025 - 16:48 UTC
This incident affected: Platform (Setup login).